Contact Email List
FAQ  •  Register  •  Login

Blown EFI fuse 93 Toyota 80series?

Moderators: toaddog, TWISTY, V8Patrol, Moderators

<<

V8 Hilux

Posts: 53

Joined: Thu Jul 24, 2008 5:29 pm

Location: melbourne

Post Thu Dec 10, 2015 10:35 am

Blown EFI fuse 93 Toyota 80series?

Hi all,

About one week ago my EFI fuse under the bonnet (behind the factory battery) blew while driving. I found it fairly quickly by just checking all the fuses. Swapped the fuse and all good.

Now the 80 has stopped again. But this time the fuse has not blown. I an quessing whatever took the fuse out has now failed? EFI relay? Any ideas. Any fault finding tips? Thanks
<<

DamTriton

User avatar

God of Athiests

Posts: 8498

Joined: Thu Aug 07, 2003 2:14 am

Location: Drownsville if not Brownsville

Post Thu Dec 10, 2015 12:21 pm

Re: Blown EFI fuse 93 Toyota 80series?

Did it stop suddenly or lost power gradually over 100m or so?

First would generally indicate ECU or injection drive failure, second would generally indicate fuel pump/fuel pressure issues.

Any more information available?
George Carlin, an American Comedian said; "Think of how stupid the average person is, and realise that half of them are stupider than that".
<<

V8 Hilux

Posts: 53

Joined: Thu Jul 24, 2008 5:29 pm

Location: melbourne

Post Thu Dec 10, 2015 1:09 pm

Re: Blown EFI fuse 93 Toyota 80series?

More information..

The first time it stopped. It felt like it had lost power. Then sort of cough and died. It would crank over fine. I was running on LPG. When it would not start on petrol. I checked the fuses and found the EFI fuse blown.

Obviously something caused the fuse to go?

The second time it stopped I was just using it to move a trailer. It was idling and it just stopped and would not start but the EFI fuse was still good.

It cranks over fine but does not start. Will look at EFI relay first. But happy to hear other things to check. Thanks
<<

stilivn

User avatar

Posts: 1124

Joined: Wed Jan 23, 2008 8:56 pm

Location: central coast down under

Post Sat Dec 19, 2015 4:32 am

Re: Blown EFI fuse 93 Toyota 80series?

Second time was it on lpg or petrol and if petrol have you tried starting it on lpg since? I would look at bypassing the lpg relay.
1993 80 series, 4" tough dog adjustable bb lift kit, LPG, 35" MTR'S

brooksy wrote:Branden Tagg.....He is the King of all f@rkups & a Gimps bitch after hours
<<

V8 Hilux

Posts: 53

Joined: Thu Jul 24, 2008 5:29 pm

Location: melbourne

Post Mon Dec 21, 2015 6:10 pm

Re: Blown EFI fuse 93 Toyota 80series?

I got it going. But don't know what had stopped it?

What would cause the EFI fuse to blow? Funny fuel pump?
Funny relay.
Something must have caused the fuse to blow in the first place. Bit stumped... Defiantly don't think the issue is solved. If it happens again or I solve it. Will post solution.

Thanks
<<

oldmate

User avatar

Posts: 1388

Joined: Tue May 06, 2008 8:12 pm

Location: Newcastle

Post Wed Dec 23, 2015 2:00 pm

Re: Blown EFI fuse 93 Toyota 80series?

The fuel pump does receive power from the EFI fused circuit. It would be my first point of call, as fuel pump failures due to ethanol fuel or lack of use when LPG is fitted are reasonably common.
The worst part about being told you have Alzheimer's, is that it doesn't just happen once.

Return to General Tech

Who is online

Users browsing this forum: No registered users and 3 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.
eBay Sniper
Time : 0.089s | 13 Queries | GZIP : Off | Load : 0.08