Contact Email List
FAQ  •  Register  •  Login

4ze1 lose of power

Moderator: Moderators

<<

boganracing

Posts: 15

Joined: Mon Apr 04, 2011 8:10 pm

Post Fri Aug 31, 2012 8:13 pm

4ze1 lose of power

hi as of a few days ago my 2.6 rodeo has lost a heap of power its not to bad on the flat but on a slight hill it will slow right down and i have to drop it back a gear or 2 these hills i used to be able to cruise up in 5th but now its sluggish as hell, and on the high if i put my foot down at 80 it will barely accelerate on the flat and no chance on speeding up even on the slitest hill, anyone got an idea of my problem?
<<

bee

Posts: 1

Joined: Fri Nov 23, 2012 8:02 pm

Post Fri Nov 23, 2012 8:22 pm

Re: 4ze1 lose of power

my mate had the same problem found it was a collapsed cat converter he smashed the centre out, he found that was his problem.

hope that helps buddy
<<

elkygem

User avatar

Posts: 10

Joined: Sat Sep 15, 2012 8:29 am

Post Sat Nov 24, 2012 8:13 am

Re: 4ze1 lose of power

yea exhaust sounds like the culprit, i have had a fair few 4z's in the past and they generally are pretty good, little things can go playing up (eg tps, airflow meter) but these generally cause surging or engine shutdown

i would be also replacing the fuel & air filter

cheers
<<

boganracing

Posts: 15

Joined: Mon Apr 04, 2011 8:10 pm

Post Sun Dec 23, 2012 2:28 pm

Re: 4ze1 lose of power

turns out the guy who last did the timing belt put the crank gear on backward which wore out the key way which created a lot of movement in the timing gear so timing was moving from acuarate to about 20 degrees out and back again got a new gear and key way and car has been fine ever since thanks guys

Return to Dmax / Isuzu / Holden / Great Wall

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.
eBay Sniper
Time : 0.077s | 15 Queries | GZIP : Off | Load : 0.25